What’s Vulnerable › Vulnerabilities
CVE-2026-116160: ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 Heap Buffer Overflow via X11 Animate
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-26
- Weakness: CWE-122
Description
ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains a heap-based buffer overflow in the X11 animate operation when processing crafted images. Attackers can supply a malicious image that, when a user runs an X11 animate operation on it, overwrites heap memory and can crash the application.
Affected products
- ImageMagick: from 7.0.0-0 before 7.1.2-33; before 6.9.13-58 — fixed in 6.9.13-58, 7.1.2-33
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-58, 7.1.2-33. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-6p6q-wfrv-ffhh
- https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-33-heap-buffer-overflow-via-x11-animate
Get alerted when CVE-2026-116160 or the next vulnerability affects your stack