What’s Vulnerable › Vulnerabilities
CVE-2026-116165: Parse Server 9.0.0 before 9.10.4-alpha.4 Unauthenticated Class Schema Deletion on MongoDB
- Severity: high (CVSS 8.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-29
- Weakness: CWE-862
Description
Parse Server before 8.6.101 and 9.0.0 before 9.10.4-alpha.4 contains a missing authorization vulnerability on MongoDB deployments that lets clients without the master key delete the stored schema of any class. Unauthenticated attackers can send REST API delete requests targeting the internal _SCHEMA collection to remove field definitions, class-level permissions, and protected fields, exposing data to unauthorized reads and modifications.
Affected products
- parse-community parse-server: from 9.0.0 before 9.10.4-alpha.4 — fixed in 9.10.4-alpha.4
How to fix
Upgrade to a fixed version: parse-community parse-server 9.10.4-alpha.4. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-qmg9-m772-5rm7
- https://www.vulncheck.com/advisories/parse-server-9.0.0-before-9.10.4-alpha.4-unauthenticated-class-schema-deletion-on-mongodb
Get alerted when CVE-2026-116165 or the next vulnerability affects your stack