What’s Vulnerable › Vulnerabilities
CVE-2026-116172: vLLM 0.22.0 before 0.24.0 DoS via Rust gRPC CandidateTokens.top_n
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-28
- Weakness: CWE-20
Description
vLLM from 0.22.0 before 0.24.0 contains an improper input validation vulnerability in the Rust gRPC converter that allows remote attackers to bypass max_logprobs limits via CandidateTokens.top_n. Attackers can send Generate or GenerateStream requests with oversized or integer-wrapping top_n values to trigger torch.topk failures that terminate EngineCore.
Affected products
- vllm-project vllm: from 0.22.0 before 0.24.0 — fixed in 0.24.0
- vllm-project vllm: from 0.22.0 before 0.24.0 — fixed in 0.24.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.24.0; vllm-project vllm 0.24.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-rwfw-xvg3-3937
- https://www.vulncheck.com/advisories/vllm-0.22.0-before-0.24.0-dos-via-rust-grpc-candidatetokens-top-n
Get alerted when CVE-2026-116172 or the next vulnerability affects your stack