What’s Vulnerable › Vulnerabilities
CVE-2026-116173: vLLM 0.22.0 before 0.24.0 Denial of Service via gRPC output_candidates.token_ids
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-28
- Weakness: CWE-20
Description
vLLM from 0.22.0 before 0.24.0 contains a denial of service vulnerability that allows remote attackers to terminate EngineCore by bypassing logprob_token_ids limits in the Rust gRPC frontend. Attackers can send Generate or GenerateStream requests with output_logprobs enabled and more than 128 output_candidates.token_ids, triggering a fatal sampler exception that crashes the engine.
Affected products
- vllm-project vllm: from 0.22.0 before 0.24.0 — fixed in 0.24.0
- vllm-project vllm: from 0.22.0 before 0.24.0 — fixed in 0.24.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.24.0; vllm-project vllm 0.24.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-6pgw-f3pv-4h8q
- https://www.vulncheck.com/advisories/vllm-0.22.0-before-0.24.0-denial-of-service-via-grpc-output-candidates-token-ids
Get alerted when CVE-2026-116173 or the next vulnerability affects your stack