What’s Vulnerable › Vulnerabilities
CVE-2026-116174: vLLM 0.22.0 before 0.24.0 Denial of Service via Rust gRPC Generate
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-29
- Weakness: CWE-20
Description
vLLM from 0.22.0 before 0.24.0 contains an improper input validation vulnerability in the Rust gRPC Generate and GenerateStream service that forwards unchecked prompt token IDs to EngineCore. Attackers can submit requests with out-of-vocabulary prompt.token_ids values to trigger a fatal embedding lookup failure that terminates EngineCore and leaves the server unhealthy.
Affected products
- vllm-project vllm: from 0.22.0 before 0.24.0 — fixed in 0.24.0
- vllm-project vllm: from 0.22.0 before 0.24.0 — fixed in 0.24.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.24.0; vllm-project vllm 0.24.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-w2v2-5662-8v5q
- https://www.vulncheck.com/advisories/vllm-0.22.0-before-0.24.0-denial-of-service-via-rust-grpc-generate
Get alerted when CVE-2026-116174 or the next vulnerability affects your stack