What’s Vulnerable › Vulnerabilities
CVE-2026-116176: vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-28
- Weakness: CWE-918
Description
vLLM from 0.9.2 before 0.24.0 contains a server-side request forgery vulnerability that allows API callers to force outbound connections by embedding a decode address in the X-Request-Id header. Attackers can make a P2pNcclConnector prefill worker ZMQ-connect to an attacker host, leaking the NCCL unique_id and KV-cache tensors or blocking the worker.
Affected products
- vllm-project vllm: from 0.9.2 before 0.24.0 — fixed in 0.24.0
- vllm-project vllm: from 0.9.2 before 0.24.0 — fixed in 0.24.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.24.0; vllm-project vllm 0.24.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-vfp2-c8pq-v6h6
- https://www.vulncheck.com/advisories/vllm-0.9.2-before-0.24.0-ssrf-via-x-request-id-in-p2pncclconnector
Get alerted when CVE-2026-116176 or the next vulnerability affects your stack