What’s Vulnerable › Vulnerabilities
CVE-2026-116178: vLLM 0.20.0 before 0.30.0 DoS via /inference/v1/generate mm_placeholders
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-28
- Weakness: CWE-20
Description
vLLM from 0.20.0 before 0.30.0 contains a denial of service vulnerability that allows remote attackers to crash the engine by sending inconsistent multimodal metadata to the disaggregated /inference/v1/generate endpoint. Attackers can replay a valid multimodal item with repeated or overlapping mm_placeholders ranges or mismatched kwargs_data and mm_hashes lists, producing a negative text span in Qwen2.5-VL position construction that terminates the engine.
Affected products
- vllm-project vllm: from 0.20.0 before 0.30.0 — fixed in 0.30.0
- vllm-project vllm: from 0.20.0 before 0.30.0 — fixed in 0.30.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.30.0; vllm-project vllm 0.30.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-34qw-q2h2-jp3m
- https://www.vulncheck.com/advisories/vllm-0.20.0-before-0.30.0-dos-via-inference-v1-generate-mm-placeholders
Get alerted when CVE-2026-116178 or the next vulnerability affects your stack