What’s Vulnerable › Vulnerabilities
CVE-2026-116179: vLLM 0.18.0 before 0.31.0 Memory Exhaustion via media_io_kwargs num_frames Override
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-28
- Weakness: CWE-770
Description
vLLM from 0.18.0 before 0.31.0 contains a resource exhaustion vulnerability that allows API clients to bypass the video/jpeg frame-count cap by overriding num_frames through media_io_kwargs. Attackers can set num_frames to -1 with a large inline video so VideoMediaIO.load_base64 decodes every frame, exhausting memory and crashing the API frontend.
Affected products
- vllm-project vllm: from 0.18.0 before 0.31.0 — fixed in 0.31.0
- vllm-project vllm: from 0.18.0 before 0.31.0 — fixed in 0.31.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.31.0; vllm-project vllm 0.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-4m6g-h9mv-wqjc
- https://www.vulncheck.com/advisories/vllm-0.18.0-before-0.31.0-memory-exhaustion-via-media-io-kwargs-num-frames-override
Get alerted when CVE-2026-116179 or the next vulnerability affects your stack