What’s Vulnerable › Vulnerabilities
CVE-2026-116181: vLLM 0.20.1 before 0.29.0 DoS and GPU Out-of-Bounds Write via stop_token_ids
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-29
- Weakness: CWE-129
Description
vLLM from 0.20.1 before 0.29.0 contains an improper input validation vulnerability that allows remote attackers to crash the engine by supplying out-of-vocabulary stop_token_ids. Attackers can send OpenAI chat, completion, generate, or batch requests with invalid IDs to terminate the engine or write outside the V2 runner's logits buffer.
Affected products
- vllm-project vllm: from 0.20.1 before 0.29.0 — fixed in 0.29.0
- vllm-project vllm: from 0.20.1 before 0.29.0 — fixed in 0.29.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.29.0; vllm-project vllm 0.29.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-w9r6-29q4-pvpr
- https://www.vulncheck.com/advisories/vllm-0.20.1-before-0.29.0-dos-and-gpu-out-of-bounds-write-via-stop-token-ids
Get alerted when CVE-2026-116181 or the next vulnerability affects your stack