What’s Vulnerable › Vulnerabilities
CVE-2026-116184: OpenRemote before 1.31.0 Cross-Realm Gateway Impersonation via Websocket
- Severity: low (CVSS 2.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-26
- Weakness: CWE-639
Description
OpenRemote before 1.31.0 contains an authorization bypass vulnerability that allows realm admins to impersonate gateways in other realms because GatewayService only checks the gateway ID, not the realm. Attackers with WRITE:ADMIN in one realm can create a service user named after another realm's gateway ID to overwrite its descendant assets and open SSH tunnels into its local network.
Affected products
- openremote core: before 1.31.0 — fixed in 1.31.0
How to fix
Upgrade to a fixed version: openremote core 1.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/openremote/core/security/advisories/GHSA-2j4x-qh6q-q8mm
- https://www.vulncheck.com/advisories/openremote-before-1.31.0-cross-realm-gateway-impersonation-via-websocket
Get alerted when CVE-2026-116184 or the next vulnerability affects your stack