What’s Vulnerable › Vulnerabilities
CVE-2026-116198: Snipe-IT before 8.7.0 Missing Encryption via Api AssetsController store
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-29
- Weakness: CWE-311
Description
Snipe-IT before 8.7.0 contains a missing encryption vulnerability in Api\AssetsController::store that writes plaintext into encrypted-flagged custom-field columns when callers lack assets.view.encrypted_custom_fields. Authenticated API users without that permission can create assets whose sensitive custom-field values persist unencrypted in the database, exposing them through backups, replicas, or direct database access.
Affected products
- grokability snipe-it: before 8.7.0 — fixed in 8.7.0
- grokability snipe-it: before 8.7.0 — fixed in 8.7.0
How to fix
Upgrade to a fixed version: grokability snipe-it 8.7.0; grokability snipe-it 8.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/grokability/snipe-it/security/advisories/GHSA-jh4g-98fm-jcqc
- https://www.vulncheck.com/advisories/snipe-it-before-8.7.0-missing-encryption-via-api-assetscontroller-store
Get alerted when CVE-2026-116198 or the next vulnerability affects your stack