What’s Vulnerable › Vulnerabilities
CVE-2026-116204: YesWiki before 4.7.0 CSRF via despam Admin Action
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-25
- Weakness: CWE-352
Description
YesWiki before 4.7.0 contains a cross-site request forgery vulnerability in the despam action (tools/security/actions/despam.php) that lets unauthenticated attackers delete or restore pages through an administrator's session. Attackers can plant an auto-submitting raw HTML form on a wiki page, so an administrator who views it posts clean, suppr[], or rev[] parameters that delete PagePrincipale, configuration pages, or overwrite current content.
Affected products
- yeswiki: before 4.7.0 — fixed in 4.7.0
How to fix
Upgrade to a fixed version: yeswiki 4.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-cv88-hx5q-vq72
- https://www.vulncheck.com/advisories/yeswiki-before-4.7.0-csrf-via-despam-admin-action
Get alerted when CVE-2026-116204 or the next vulnerability affects your stack