What’s Vulnerable › Vulnerabilities
CVE-2026-116206: YesWiki 4.2.0 before 4.7.0 Stored XSS via Comment Raw-HTML Syntax
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-29
- Weakness: CWE-79
Description
YesWiki from 4.2.0 before 4.7.0 contains a stored cross-site scripting vulnerability that allows authenticated users to inject script into comment bodies using the wakka raw-HTML syntax. Attackers can post comments via the /api/comments endpoint that render unescaped through the Twig raw filter, executing JavaScript in administrators' and visitors' sessions.
Affected products
- yeswiki: from 4.2.0 before 4.7.0 — fixed in 4.7.0
How to fix
Upgrade to a fixed version: yeswiki 4.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-wq96-vjjh-hfc6
- https://www.vulncheck.com/advisories/yeswiki-4.2.0-before-4.7.0-stored-xss-via-comment-raw-html-syntax
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-wq96-vjjh-hfc6
Get alerted when CVE-2026-116206 or the next vulnerability affects your stack