What’s Vulnerable › Vulnerabilities
CVE-2026-116541: netty-tcnative before 2.0.84.Final Denial of Service via BIO Write Overcount
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-26
- Weakness: CWE-682
Description
Netty netty-tcnative before 2.0.84.Final contains a denial of service vulnerability in the tcn_write_to_bytebuffer BIO write callback that overreports bytes consumed. Remote TLS 1.3 peers can provoke queued post-handshake records like NewSessionTicket or KeyUpdate to truncate flights, fail connections, or abort the JVM process.
Affected products
- netty-tcnative: before 2.0.84.Final — fixed in 2.0.84.Final
- netty-tcnative-boringssl-static: before 2.0.84.Final — fixed in 2.0.84.Final
How to fix
Upgrade to a fixed version: netty-tcnative 2.0.84.Final; netty-tcnative-boringssl-static 2.0.84.Final. Check the vendor advisory for mitigations.
References
- https://github.com/netty/netty-tcnative
- https://github.com/netty/netty-tcnative/blob/netty-tcnative-parent-2.0.83.Final/openssl-dynamic/src/main/c/ssl.c#L240
- https://github.com/netty/netty-tcnative/commit/e31df4a5885b35085fdfa3e2dca7c1f705d4745b
- https://github.com/netty/netty-tcnative/releases/tag/netty-tcnative-parent-2.0.84.Final
- https://github.com/netty/netty-tcnative/security/advisories/GHSA-9xr3-jwv4-r489
- https://www.vulncheck.com/advisories/netty-tcnative-before-2.0.84-final-denial-of-service-via-bio-write-overcount
Get alerted when CVE-2026-116541 or the next vulnerability affects your stack