What’s Vulnerable › Vulnerabilities

CVE-2026-116593: Apache Kafka: Kafka Connect configuration provider values exposed via validation REST API endpoint

Description

Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its REST API to validate connector configurations. Apache Kafka Connect also support Configuration Providers which enable to hide the values of sensitive configuration and only resolve them at runtime.  An attacker with access to the validate endpoint can use it to resolve and return plaintext values via any of the configuration providers installed on a Connect worker. Users are recommended to upgrade to version 4.2.2, 4.3.2, 4.4.0 or above, which fix this issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Kafka 4.2.2, 4.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-116593 or the next vulnerability affects your stack