What’s Vulnerable › Vulnerabilities
CVE-2026-116817: OpenPanel before 3.0.0 Missing Authentication on Worker Bull Board
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-27
- Weakness: CWE-306
Description
OpenPanel before 3.0.0 contains a missing authentication vulnerability that allows unauthenticated attackers to access the Bull Board dashboard served on the worker HTTP port. Attackers can query /api/queues and call mutating Bull Board APIs to add, retry, or clean jobs and read queue data, metrics, and datastore health.
Affected products
- Openpanel-dev openpanel: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: Openpanel-dev openpanel 3.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/Openpanel-dev/openpanel/commit/193e1e3ae01aa5208b3bee754ddee2c7ce33b38d
- https://github.com/Openpanel-dev/openpanel/commit/fb0b56977c82aa1ade61449df86726b0c1490f54
- https://github.com/Openpanel-dev/openpanel/security/advisories/GHSA-r627-6vrh-65p9
- https://www.vulncheck.com/advisories/openpanel-before-3.0.0-missing-authentication-on-worker-bull-board
Get alerted when CVE-2026-116817 or the next vulnerability affects your stack