What’s Vulnerable › Vulnerabilities
CVE-2026-116824: YesWiki before 4.7.0 Stored XSS via Referer Header in referrers_sites Handler
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-31
- Weakness: CWE-79
Description
YesWiki before 4.7.0 contains a stored cross-site scripting vulnerability in handlers/page/referrers_sites.php that allows unauthenticated attackers to inject scripts via crafted Referer headers. Attackers can send a Referer hostname containing HTML metacharacters that renders unescaped, executing JavaScript for any referrer-sites page visitor to perform same-origin authenticated actions.
Affected products
- yeswiki: before 4.7.0 — fixed in 4.7.0
How to fix
Upgrade to a fixed version: yeswiki 4.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-xcwg-2pj5-3qm4
- https://www.vulncheck.com/advisories/yeswiki-before-4.7.0-stored-xss-via-referer-header-in-referrers-sites-handler
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-xcwg-2pj5-3qm4
Get alerted when CVE-2026-116824 or the next vulnerability affects your stack