What’s Vulnerable › Vulnerabilities
CVE-2026-116828: YesWiki before 4.7.0 SQL Injection via despam.php INTERVAL operand
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-31
- Weakness: CWE-89
Description
YesWiki before 4.7.0 contains a sql injection vulnerability in despam.php where the from parameter is escaped but placed in an unquoted INTERVAL position. Authenticated administrators can inject SQL via the from POST parameter to perform blind reads of the database including user password hashes.
Affected products
- yeswiki: before 4.7.0 — fixed in 4.7.0
How to fix
Upgrade to a fixed version: yeswiki 4.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-w7cp-76pj-w4m5
- https://www.vulncheck.com/advisories/yeswiki-before-4.7.0-sql-injection-via-despam-php-interval-operand
- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-w7cp-76pj-w4m5
Get alerted when CVE-2026-116828 or the next vulnerability affects your stack