What’s Vulnerable › Vulnerabilities
CVE-2026-116870
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-27 · updated 2026-10-27
- Weakness: CWE-1289
Description
In affected versions of Octopus Server, OIDC token issuer validation was performed inconsistently. This could result in a token issued from a suitably configured non legitimate issuer being accepted as a token belonging to a service account from a legitimate trusted issuer. Exploitation requires a service account with at least one OIDC identity configured. An attacker would also need to know or guess some details of that identity in order to be in a position to attempt exploitation.
Affected products
- Octopus Deploy Octopus Server: from 2024.1.0 before 2026.1.11781; from 2026.2.0 before 2026.2.13438; from 2026.3.0 before 2026.3.15816 — fixed in 2026.1.11781, 2026.2.13438, 2026.3.15816
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2026.1.11781, 2026.2.13438, 2026.3.15816. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-116870 or the next vulnerability affects your stack