What’s Vulnerable › Vulnerabilities
CVE-2026-116900: REDAXO before 5.21.4 Stored XSS via Media and Link Input Widgets
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-27 · updated 2026-10-31
- Weakness: CWE-79
Description
REDAXO before 5.21.4 contains a stored cross-site scripting vulnerability that allows content editors to inject HTML by storing unescaped values rendered by media, medialist, link and linklist widgets. Attackers can submit crafted REX_INPUT_MEDIA or REX_INPUT_LINK values that break out of the value attribute, executing script in administrators' backend sessions to hijack accounts.
Affected products
- redaxo core: before 5.21.4 — fixed in 5.21.4
How to fix
Upgrade to a fixed version: redaxo core 5.21.4. Check the vendor advisory for mitigations.
References
- https://github.com/redaxo/core/security/advisories/GHSA-5wmj-5x79-rr87
- https://www.vulncheck.com/advisories/redaxo-before-5.21.4-stored-xss-via-media-and-link-input-widgets
Get alerted when CVE-2026-116900 or the next vulnerability affects your stack