What’s Vulnerable › Vulnerabilities
CVE-2026-117532: REDAXO Core 5.3.0 before 5.21.4 Authentication Bypass via History Plugin
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-27 · updated 2026-10-27
- Weakness: CWE-287
Description
REDAXO core from 5.3.0 before 5.21.4 contains an authentication bypass vulnerability in the structure/history plugin that allows unauthenticated attackers to forge temporary login tokens. Attackers can force the session-tied secret into a predictable state and forge tokens for accounts like admin, gaining backend access and code execution outside live mode.
Summary
REDAXO Core versions from 5.3.0 before 5.21.4 contain an authentication bypass in the structure/history plugin. Unauthenticated attackers can force the session-tied secret into a predictable state and forge temporary login tokens for accounts such as admin, gaining backend access and code execution outside live mode. Rated CVSS 9.8 critical; it is not listed in CISA KEV, so no known in-the-wild exploitation is confirmed. Upgrade to 5.21.4 or later, and restrict backend access until patched.
تحتوي إصدارات REDAXO Core من 5.3.0 وحتى ما قبل 5.21.4 على ثغرة تجاوز للمصادقة في إضافة structure/history. يستطيع المهاجمون غير المصادق عليهم دفع السر المرتبط بالجلسة إلى حالة قابلة للتوقع وتزوير رموز دخول مؤقتة لحسابات مثل admin، ما يتيح الوصول إلى لوحة التحكم وتنفيذ تعليمات برمجية خارج وضع live. صُنّفت الثغرة بدرجة 9.8 حرجة، وهي غير مدرجة في CISA KEV، لذا لا يوجد تأكيد لاستغلالها فعلياً. يجب الترقية إلى 5.21.4 أو أحدث، وتقييد الوصول إلى لوحة التحكم حتى تركيب التحديث.
Affected products
- redaxo core: from 5.3.0 before 5.21.4 — fixed in 5.21.4
How to fix
Upgrade to a fixed version: redaxo core 5.21.4. Check the vendor advisory for mitigations.
References
- https://github.com/redaxo/core/security/advisories/GHSA-px8f-whj8-hrpq
- https://www.vulncheck.com/advisories/redaxo-core-5.3.0-before-5.21.4-authentication-bypass-via-history-plugin
Get alerted when CVE-2026-117532 or the next vulnerability affects your stack