What’s Vulnerable › Vulnerabilities
CVE-2026-11806: IBM WebSphere Application Server Liberty is affected by a an arbitrary file read vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-10-25
- Weakness: CWE-444
Description
IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.6 is affected by an arbitrary file read vulnerability with the restConnector-2.0 feature enabled.
Affected products
- IBM WebSphere Application Server: from 17.0.0.3 before 26.0.0.7 — fixed in 26.0.0.7
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 26.0.0.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-11806 or the next vulnerability affects your stack