What’s Vulnerable › Vulnerabilities

CVE-2026-11827: Insufficiently Protected Credentials in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 9.5 before 18.11.7, 19.0 before 19.0.4, and 19.1 before 19.1.2 that under certain conditions could have allowed an authenticated user with maintainer-role permissions to obtain another user's stored credentials due to improper authorization controls.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.11.7, 19.0.4, 19.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-11827 or the next vulnerability affects your stack