What’s Vulnerable › Vulnerabilities
CVE-2026-11832: Dancer2::Plugin::Auth::OAuth versions before 0.22 for Perl default to a predictable nonce
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-15 · updated 2026-10-25
- Weakness: CWE-338
Description
Dancer2::Plugin::Auth::OAuth versions before 0.22 for Perl default to a predictable nonce. The default nonce was generated using an MD5 hash of the epoch time, which is predictable.
Affected products
- BIAFRA Dancer2::Plugin::Auth::OAuth: before 0.22 — fixed in 0.22
How to fix
Upgrade to a fixed version: BIAFRA Dancer2::Plugin::Auth::OAuth 0.22. Check the vendor advisory for mitigations.
References
- https://datatracker.ietf.org/doc/html/rfc5849#section-3.3
- https://datatracker.ietf.org/doc/html/rfc5849#section-4.9
- https://metacpan.org/release/BIAFRA/Dancer2-Plugin-Auth-OAuth-0.22/changes
- https://www.cve.org/CVERecord?id=CVE-2025-22376
Get alerted when CVE-2026-11832 or the next vulnerability affects your stack