What’s Vulnerable › Vulnerabilities

CVE-2026-1184: Deserialization of Untrusted Data in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 11.9 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that could have allowed an unauthenticated user to cause denial of service by uploading a specially crafted file due to improper validation.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.10.6, 18.11.3, 18.9.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-1184 or the next vulnerability affects your stack