What’s Vulnerable › Vulnerabilities
CVE-2026-118683: MONAI 1.2.0 before 1.6.1 Code Execution via bundle configs/logging.conf
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-28 · updated 2026-10-29
- Weakness: CWE-94
Description
MONAI from 1.2.0 before 1.6.1 contains a remote code execution vulnerability in ConfigWorkflow.__init__, which passes a bundle's configs/logging.conf to logging.config.fileConfig that eval()s handler class and args fields. Attackers can publish a malicious bundle whose logging.conf runs arbitrary Python at workflow construction when a victim loads or runs the bundle.
Affected products
- Project-MONAI MONAI: from 1.2.0 before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: Project-MONAI MONAI 1.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-wvpx-5qmp-46g3
- https://www.vulncheck.com/advisories/monai-1.2.0-before-1.6.1-code-execution-via-bundle-configs-logging-conf
Get alerted when CVE-2026-118683 or the next vulnerability affects your stack