What’s Vulnerable › Vulnerabilities

CVE-2026-118696

Description

In JetBrains IntelliJ IDEA, PyCharm, PhpStorm, RubyMine and WebStorm before 2026.3, 2026.2.4, 2026.1.5.1, and 2025.3.6.2; GoLand before 2026.3, 2026.2.4, 2026.1.5.1, and 2025.3.5.2; Rider before 2026.3, 2026.2.4, 2026.1.5.3, and 2025.3.5.3; CLion before 2026.3, 2026.2.4.1, 2026.1.5.2, and 2025.3.6.3; DataGrip before 2026.3, 2026.2.6.1, 2026.1.4.1, and 2025.3.6.1; RustRover before 2026.3, 2026.2.5, 2026.1.4.1, and 2025.3.7.1; DataSpell before 2026.1.3.1 and 2025.3.3.1, the embedded browser trusted revoked intermediate certificates

Affected products

How to fix

Upgrade to a fixed version: JetBrains CLion 2026.2.4.1, 2026.1.5.2, 2025.3.6.3; JetBrains DataGrip 2026.2.6.1, 2026.1.4.1, 2025.3.6.1; JetBrains DataSpell 2026.1.3.1, 2025.3.3.1; JetBrains GoLand 2026.2.4, 2026.1.5.1, 2025.3.5.2; JetBrains IntelliJ IDEA 2026.2.4, 2026.1.5.1, 2025.3.6.2; JetBrains PhpStorm 2026.2.4, 2026.1.5.1, 2025.3.6.2; JetBrains PyCharm 2026.2.4, 2026.1.5.1, 2025.3.6.2; JetBrains Rider 2026.2.4, 2026.1.5.3, 2025.3.5.3; JetBrains RubyMine 2026.2.4, 2026.1.5.1, 2025.3.6.2; JetBrains RustRover 2026.2.5, 2026.1.4.1, 2025.3.7.1; JetBrains WebStorm 2026.2.4, 2026.1.5.1, 2025.3.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-118696 or the next vulnerability affects your stack