What’s Vulnerable › Vulnerabilities
CVE-2026-118905: nvm_ls lets an untrusted version string inject sed commands, executing arbitrary commands with GNU sed
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-29 · updated 2026-10-29
- Weakness: CWE-78
Description
Node Version Manager (nvm) is a POSIX-compliant shell function for managing multiple node.js versions. In versions 0.31.2 through 0.40.5, `nvm_ls` filters installed versions with a sed program that embeds the requested version pattern in a `\#...#` address, escaping `.` (and, since 0.40.4, `#`) but not backslash. A version string containing `#` (or `\#`) therefore closes the address early, and the rest of it is parsed as sed commands: with GNU sed, the `e` command runs a shell command as the user; with BSD sed, the `w` and `r` commands write and read files. This is reachable whenever an attacker-influenced version string is passed to `nvm use`, `nvm which`, `nvm ls`, `nvm version`, `nvm run`, or `nvm exec`, or to `nvm-exec` via `NODE_VERSION`, and at least one version is installed. nvm's own `.nvmrc` parser strips comments, so a bare `nvm use` is not affected; however, the bash `cdnvm` and zsh `load-nvmrc` auto-switch hooks documented in the README read `.nvmrc` as-is and pass it to `nvm ls` and `nvm version`, so a user with one of those hooks installed runs the attacker's command just by changing into a directory under a malicious `.nvmrc`; scripts that run `nvm use "$(cat .nvmrc)"` are affected the same way. Version 0.40.6 passes any version pattern containing `#` or a newline through the `.nvmrc` content parser first, so no `#` reaches the sed program.
Affected products
- nvm-sh nvm: from 0.31.2 before 0.40.6 — fixed in 0.40.6
How to fix
Upgrade to a fixed version: nvm-sh nvm 0.40.6. Check the vendor advisory for mitigations.
References
- https://github.com/nvm-sh/nvm/commit/82315e2b189528a006da6701eac30e8c364ffd22
- https://github.com/nvm-sh/nvm/pull/3854
- https://github.com/nvm-sh/nvm/releases/tag/v0.40.6
- https://github.com/nvm-sh/nvm/security/advisories/GHSA-vgqf-vc3m-4wv3
Get alerted when CVE-2026-118905 or the next vulnerability affects your stack