What’s Vulnerable › Vulnerabilities
CVE-2026-118984: OmniRoute 3.8.0 before 3.8.52 Unverified Password Change via /api/settings/require-login
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-29 · updated 2026-10-29
- Weakness: CWE-620
Description
OmniRoute 3.8.0 before 3.8.52 contains an unverified password change vulnerability that allows holders of manage- or admin-scoped API keys or oma_ access tokens to change the management password without the current password. Attackers can send POST requests to /api/settings/require-login to lock out the operator, take over dashboard login, or disable the login requirement entirely.
Affected products
- cheaper-inference OmniRoute: from 3.8.0 before 3.8.52 — fixed in 3.8.52
How to fix
Upgrade to a fixed version: cheaper-inference OmniRoute 3.8.52. Check the vendor advisory for mitigations.
References
- https://github.com/cheaper-inference/OmniRoute
- https://github.com/cheaper-inference/OmniRoute/blob/c1e30b7676975feb298b49eff6ff58923c04b89e/src/app/api/settings/require-login/route.ts#L90-L130
- https://github.com/cheaper-inference/OmniRoute/blob/c1e30b7676975feb298b49eff6ff58923c04b89e/src/app/api/settings/route.ts#L374-L422
- https://github.com/cheaper-inference/OmniRoute/commit/dde27f4964872c9b43cfd5b8f532693f6c018af6
- https://github.com/cheaper-inference/OmniRoute/pull/16897
- https://github.com/cheaper-inference/OmniRoute/releases/tag/v3.8.52
- https://www.vulncheck.com/advisories/omniroute-3.8.0-before-3.8.52-unverified-password-change-via-api-settings-require-login
Get alerted when CVE-2026-118984 or the next vulnerability affects your stack