What’s Vulnerable › Vulnerabilities
CVE-2026-119025: open 7.2.0 before 11.0.0 OS Command Injection via PowerShell on Windows
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-29 · updated 2026-10-29
- Weakness: CWE-78
Description
open 7.2.0 before 11.0.0 contains an OS command injection vulnerability that allows attackers to execute PowerShell code by supplying crafted URLs on Windows and WSL. Attackers can embed $(...) subexpressions in URLs, such as OAuth authorization_endpoint values from malicious MCP servers, which execute when index.js passes them unescaped to powershell -EncodedCommand.
Affected products
- anomalyco opencode: from 1.0.137 before 1.18.33 — fixed in 1.18.33
- modelcontextprotocol inspector: from 2.0.0 before 2.12.0 — fixed in 2.12.0
- sindresorhus open: from 7.2.0 before 11.0.0 — fixed in 11.0.0
How to fix
Upgrade to a fixed version: anomalyco opencode 1.18.33; modelcontextprotocol inspector 2.12.0; sindresorhus open 11.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/anomalyco/opencode/commit/29f07e0c69ad8668e0e15b0eb54f2fcb342af98c
- https://github.com/anomalyco/opencode/pull/51414
- https://github.com/modelcontextprotocol/inspector/security/advisories/GHSA-q978-78c7-phqw
- https://github.com/sindresorhus/open/blob/v10.2.0/index.js#L189-L203
- https://github.com/sindresorhus/open/blob/v7.2.0/index.js#L60-L99
- https://github.com/sindresorhus/open/commit/274d70446bf38a7b7d50b214dd3962ef8ea9320d
- https://github.com/sindresorhus/open/releases/tag/v11.0.0
- https://www.vulncheck.com/advisories/open-7.2.0-before-11.0.0-os-command-injection-via-powershell-on-windows
Get alerted when CVE-2026-119025 or the next vulnerability affects your stack