What’s Vulnerable › Vulnerabilities
CVE-2026-119118: Crawl4AI before 0.9.5 Improper Certificate Validation via Hard-coded Chromium Flags
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-29 · updated 2026-10-29
- Weakness: CWE-295
Description
Crawl4AI before 0.9.5 contains an improper certificate validation vulnerability that allows network attackers to intercept crawls because Chromium always launches with --ignore-certificate-errors. Man-in-the-middle or DNS-controlling attackers can serve forged content to the crawler and read cookies and headers sent, while hard-coded --no-sandbox also overrides CRAWL4AI_CHROMIUM_SANDBOX.
Affected products
- unclecode crawl4ai: before 0.9.5 — fixed in 0.9.5
How to fix
Upgrade to a fixed version: unclecode crawl4ai 0.9.5. Check the vendor advisory for mitigations.
References
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-j2qh-f73r-mg3q
- https://www.vulncheck.com/advisories/crawl4ai-before-0.9.5-improper-certificate-validation-via-hard-coded-chromium-flags
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-j2qh-f73r-mg3q
Get alerted when CVE-2026-119118 or the next vulnerability affects your stack