What’s Vulnerable › Vulnerabilities
CVE-2026-119119: Crawl4AI before 0.9.5 Denial of Service via Unbounded CrawlerRunConfig Delay Fields
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-29 · updated 2026-10-29
- Weakness: CWE-770
Description
Crawl4AI before 0.9.5 contains a denial of service vulnerability in the Docker API server where _clamp_untrusted() fails to cap the delay_before_return_html, mean_delay, and max_range fields of untrusted CrawlerRunConfig bodies. Unauthenticated attackers can send huge values to /crawl or /crawl/stream to hold browser pages or stall the rate limiter, exhausting the page pool and blocking other crawls.
Affected products
- unclecode crawl4ai: before 0.9.5 — fixed in 0.9.5
How to fix
Upgrade to a fixed version: unclecode crawl4ai 0.9.5. Check the vendor advisory for mitigations.
References
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-rhjm-7hj7-75fx
- https://www.vulncheck.com/advisories/crawl4ai-before-0.9.5-denial-of-service-via-unbounded-crawlerrunconfig-delay-fields
Get alerted when CVE-2026-119119 or the next vulnerability affects your stack