What’s Vulnerable › Vulnerabilities
CVE-2026-119121: Crawl4AI 0.9.0 before 0.9.5 JavaScript Injection via css_selector and wait_for
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-29 · updated 2026-10-29
- Weakness: CWE-95
Description
Crawl4AI from 0.9.0 before 0.9.5 contains a JavaScript injection vulnerability in the Docker API server that allows authenticated API clients to run arbitrary JavaScript in the crawl page via allowlisted css_selector and wait_for fields. Attackers can inject quotes into css_selector or supply js: conditions in wait_for, bypassing the js_code block to alter page state and returned crawl content.
Affected products
- unclecode crawl4ai: from 0.9.0 before 0.9.5 — fixed in 0.9.5
How to fix
Upgrade to a fixed version: unclecode crawl4ai 0.9.5. Check the vendor advisory for mitigations.
References
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-qj46-wp7m-rgj8
- https://www.vulncheck.com/advisories/crawl4ai-0.9.0-before-0.9.5-javascript-injection-via-css-selector-and-wait-for
Get alerted when CVE-2026-119121 or the next vulnerability affects your stack