What’s Vulnerable › Vulnerabilities
CVE-2026-119277: MariaDB Connector/J: Rogue server can make the client read past the packet through server-declared lengths
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-29 · updated 2026-10-30
- Weakness: CWE-125
Description
MariaDB Connector/J is used to connect applications developed in Java to MariaDB and MySQL databases. From 3.0.0 until 3.3.7, 3.4.5, and 3.5.11, decoders for OK packet session-state blocks, column definition packets, text row data, or binary row data used server-declared lengths without confirming that the requested bytes remained in the receive buffer. The decoders could position reads, create sub-buffers, or decode strings beyond the packet boundary. A malicious or compromised server, or a machine-in-the-middle attacker, could trigger unchecked ArrayIndexOutOfBoundsException or IllegalArgumentException failures inside JDBC calls and terminate connection handling. This issue is fixed in versions 3.3.7, 3.4.5, and 3.5.11.
Affected products
- mariadb-corporation mariadb-connector-j: from 3.0.0, < 3.3.7; from 3.4.0, < 3.4.5; from 3.5.0, < 3.5.11
References
- https://github.com/mariadb-corporation/mariadb-connector-j/commit/49c92adfcf816853e324031ba9762a69444cfd12
- https://github.com/mariadb-corporation/mariadb-connector-j/commit/52538206298db39062ad67939f1446b767cacde4
- https://github.com/mariadb-corporation/mariadb-connector-j/commit/ea8c7b6537e50053444188a9a3fd9cae99550f56
- https://github.com/mariadb-corporation/mariadb-connector-j/releases/tag/3.3.7
- https://github.com/mariadb-corporation/mariadb-connector-j/releases/tag/3.4.5
- https://github.com/mariadb-corporation/mariadb-connector-j/releases/tag/3.5.11
- https://github.com/mariadb-corporation/mariadb-connector-j/security/advisories/GHSA-wfxr-v78w-p49r
Get alerted when CVE-2026-119277 or the next vulnerability affects your stack