What’s Vulnerable › Vulnerabilities
CVE-2026-119576: ArcadeDB from 21.12.1 before 26.10.2 GraphQL Schema Replacement via Read-Only Query Endpoint
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-30 · updated 2026-10-30
- Weakness: CWE-862
Description
ArcadeDB from 21.12.1 before 26.10.2 contains an authorization bypass vulnerability that allows users with only readRecord to replace the shared GraphQL schema via the read-only query endpoint. Attackers can send a GraphQL type definition with a crafted @sql directive to /api/v1/query/{database}, altering query results returned to other users including administrators.
Affected products
- ArcadeData arcadedb: from 21.12.1 before 26.10.2 — fixed in 26.10.2
How to fix
Upgrade to a fixed version: ArcadeData arcadedb 26.10.2. Check the vendor advisory for mitigations.
References
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-773f-9j7c-cr54
- https://www.vulncheck.com/advisories/arcadedb-from-21.12.1-before-26.10.2-graphql-schema-replacement-via-read-only-query-endpoint
Get alerted when CVE-2026-119576 or the next vulnerability affects your stack