What’s Vulnerable › Vulnerabilities

CVE-2026-12085: IBM DevOps Deploy / IBM UrbanCode Deploy (UCD) is susceptable to an Insertion of Sensitive Information Into Sent Data vulnerability

Description

IBM UCD - IBM UrbanCode Deploy 7.3 through 7.3.2.18 and IBM UCD - IBM DevOps Deploy 8.0 through 8.0.1.13, 8.1 through 8.1.2.6, and 8.2 through 8.2.1.0 IBM DevOps Deploy could disclose sensitive configurations and secrets to authenticated users in API responses that could be used in further attacks against the system.

Affected products

How to fix

Upgrade to a fixed version: IBM DevOps Deploy 8.0.1.14, 8.1.2.7, 8.2.1.0; IBM UrbanCode Deploy 7.3.2.19. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-12085 or the next vulnerability affects your stack