What’s Vulnerable › Vulnerabilities
CVE-2026-12116: CVE-2026-12116
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-09 · updated 2026-10-25
Description
A vulnerability in the Xerte Online Tools allows for RCE through the antivirus binary path in the tools server settings, which can be changed to a PHP interpreter, allowing an attacker to upload PHP data that will then be executed.
Affected products
- Xerte Online Tools: before v3.15.5; before 3.14.6 — fixed in 3.14.6, v3.15.5
How to fix
Upgrade to a fixed version: Xerte Online Tools 3.14.6, v3.15.5. Check the vendor advisory for mitigations.
References
- https://github.com/thexerteproject/xerteonlinetoolkits/commit/8ef20628f80bd88bd1fe3e5844a9116a910086b7
- https://github.com/thexerteproject/xerteonlinetoolkits/issues/1543
- https://www.xerte.org.uk/index.php/en/news/blog/80-news/364-xerte-3-14-and-3-15-important-security-update
Get alerted when CVE-2026-12116 or the next vulnerability affects your stack