What’s Vulnerable › Vulnerabilities
CVE-2026-12171: auto-changelog: code execution via untrusted in-repository configuration (handlebarsSetup/plugins), plus argument injection, path traversal, and SSRF
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-05 · updated 2026-10-06
- Weakness: CWE-22
Description
auto-changelog before 2.6.1 merges configuration from inside the target repository (the .auto-changelog file and the auto-changelog key in package.json) into its options, and honors security-sensitive options from that untrusted source. The handlebarsSetup option is passed to require(), so running auto-changelog over attacker-controlled repository content (for example, in a CI workflow that checks out an untrusted pull request head, or locally on a forked or third-party repository) executes attacker-chosen code with the privileges of the invoking user or CI job, including access to workflow secrets, without the repository dependencies ever being installed. The plugins option similarly loads attacker-controlled modules from the repository. Under the same conditions, appendGitLog/appendGitTag allow git argument injection (e.g. --output= to write arbitrary files), output allows writing attacker-influenced content to arbitrary paths, and template causes an outbound request to an attacker-chosen URL. Version 2.6.1 treats in-repository configuration as untrusted and refuses to run when it sets these options, unless the new --unsafe-config flag is passed.
Affected products
- cookpete auto-changelog: before 2.6.1 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: cookpete auto-changelog 2.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/cookpete/auto-changelog/commit/1d02a48a0a57c69a3cd268aca375d64d50877c1a
- https://github.com/cookpete/auto-changelog/security/advisories/GHSA-xpvr-2hvx-m8q4
- https://github.com/cookpete/auto-changelog/security/advisories/GHSA-xpvr-2hvx-m8q4
Get alerted when CVE-2026-12171 or the next vulnerability affects your stack