What’s Vulnerable › Vulnerabilities
CVE-2026-12241: Advanced Woo Labels – Product Labels & Badges for WooCommerce <= 2.51 - Improper Authorization to Authenticated (Subscriber+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-03
- Weakness: CWE-79
Description
The Advanced Woo Labels – Product Labels & Badges for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to an improperly secure capability check on the 'save_meta_boxes' function in all versions up to, and including, 2.51. This makes it possible for authenticated attackers, with Contributor-level access and above, to create AWS labels that are rendered without proper escaping. The vulnerability was partially patched in version 2.46.
Affected products
References
- https://kramakit.com/guide/free-version-changelog-awl/
- https://plugins.trac.wordpress.org/browser/advanced-woo-labels/trunk/advanced-woo-labels.php#L219
- https://plugins.trac.wordpress.org/browser/advanced-woo-labels/trunk/includes/admin/class-awl-admin.php#L121
- https://plugins.trac.wordpress.org/browser/advanced-woo-labels/trunk/includes/class-awl-label-view.php#L145
- https://plugins.trac.wordpress.org/browser/advanced-woo-labels/trunk/includes/class-awl-taxonomy.php#L116
- https://plugins.trac.wordpress.org/browser/advanced-woo-labels/trunk/includes/class-awl-taxonomy.php#L78
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a08d9118-3615-4f8e-a1cc-ba7e7873b7e5?source=cve
Get alerted when CVE-2026-12241 or the next vulnerability affects your stack