What’s Vulnerable › Vulnerabilities
CVE-2026-12394: MemberGlut < 1.1.5 - Unauthenticated Privilege Escalation to Administrator
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-27 · updated 2026-07-27
- Weakness: CWE-269
Description
The MemberGlut WordPress plugin before 1.1.5 does not validate the role chosen during front-end registration, allowing unauthenticated users to register an account with an arbitrary role, including administrator, leading to full site compromise.
Affected products
- MemberGlut: before 1.1.5 — fixed in 1.1.5
How to fix
Upgrade to a fixed version: MemberGlut 1.1.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12394 or the next vulnerability affects your stack