What’s Vulnerable › Vulnerabilities
CVE-2026-12411: Broken Access Control in Canonical LXD DevLXD API
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-26 · updated 2026-10-25
- Weakness: CWE-639
Description
Broken Access Control in the devLXDInstancePatchHandler component of Canonical LXD allows an untrusted guest to mount, read, and overwrite another guest's custom storage volume via a crafted device PATCH request over /dev/lxd when security.devlxd.management.volumes is enabled.
Affected products
- Canonical LXD: from 6.6 before 6.9 — fixed in 6.9
How to fix
Upgrade to a fixed version: Canonical LXD 6.9. Check the vendor advisory for mitigations.
References
- https://github.com/canonical/lxd/pull/18585
- https://github.com/canonical/lxd/security/advisories/GHSA-hhf9-qw4v-72xp
- https://github.com/canonical/lxd/security/advisories/GHSA-hhf9-qw4v-72xp
Get alerted when CVE-2026-12411 or the next vulnerability affects your stack