What’s Vulnerable › Vulnerabilities
CVE-2026-1245: CVE-2026-1245
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-20 · updated 2026-06-17
- Weakness: CWE-94
Description
A code injection vulnerability in the binary-parser library prior to version 2.3.0 allows arbitrary JavaScript code execution when untrusted values are used in parser field names or encoding parameters. The library directly interpolates these values into dynamically generated code without sanitization, enabling attackers to execute arbitrary code in the context of the Node.js process.
Affected products
- binary-parser: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: binary-parser 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/keichi/binary-parser
- https://github.com/keichi/binary-parser/pull/283
- https://kb.cert.org/vuls/id/102648
- https://www.npmjs.com/package/binary-parser
- https://www.kb.cert.org/vuls/id/102648
Get alerted when CVE-2026-1245 or the next vulnerability affects your stack