What’s Vulnerable › Vulnerabilities
CVE-2026-12511: AI Engine < 3.5.5 - Editor+ Arbitrary File Write via Path Traversal
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-07-14
Description
The AI Engine WordPress plugin before 3.5.5 does not sanitize a user-supplied filename before using it to write a downloaded file, allowing authenticated users with editor-level access to write attacker-controlled bytes to an arbitrary location on the server via path traversal.
Affected products
- AI Engine: before 3.5.5 — fixed in 3.5.5
How to fix
Upgrade to a fixed version: AI Engine 3.5.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12511 or the next vulnerability affects your stack