What’s Vulnerable › Vulnerabilities
CVE-2026-12516: Fediverse Embeds < 1.5.8 - Unauthenticated SSRF via Media Proxy
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-09 · updated 2026-07-09
Description
The Fediverse Embeds WordPress plugin before 1.5.8 does not validate the destination of the server-side request performed by an unauthenticated media-proxying endpoint, allowing anonymous users to make the site fetch arbitrary URLs, including internal and private-network addresses, and read back the response body. This results in a full-read Server-Side Request Forgery and open proxy.
Affected products
- Fediverse Embeds: before 1.5.8 — fixed in 1.5.8
How to fix
Upgrade to a fixed version: Fediverse Embeds 1.5.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12516 or the next vulnerability affects your stack