What’s Vulnerable › Vulnerabilities
CVE-2026-12569: PTC Windchill and FlexPLM Improper Input Validation Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-06-25
- EPSS: 46.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-18 · updated 2026-08-01
- Weakness: CWE-20
Description
A critical remote code execution (RCE) vulnerability has been reported in PTC Windchill PDMlink and PTC FlexPLM. The vulnerability may be exploited through the deserialization of untrusted data. * This advisory also applies to all CPS versions * The identified vulnerability also impacts Windchill and FlexPLM releases prior to 11.0 M030
Affected products
- PTC FlexPLM: through 11.0m030; 11.1m020, 11.2.1.0, 12.0.0.0, 12.0.2.0, 12.1.3.0, 13.0.2.0 (+1)
- PTC Windchill PDMLink: before 11.0m030; 11.0m030, 11.1m020, 11.2.1.0, 12.0.2.0, 12.1.2.0, 13.0.2.0 (+4) — fixed in 11.0m030
How to fix
Upgrade to a fixed version: PTC Windchill PDMLink 11.0m030. Check the vendor advisory for mitigations.
References
- https://www.ptc.com/en/support/article/CS473270
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-12569
Get alerted when CVE-2026-12569 or the next vulnerability affects your stack