What’s Vulnerable › Vulnerabilities
CVE-2026-12582: Library Management System < 3.5.8 - Unauthenticated SQL Injection via book_id
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-13 · updated 2026-07-13
Description
The Library Management System WordPress plugin before 3.5.8 does not sanitize and escape a user-supplied parameter before using it in a SQL statement, allowing unauthenticated attackers to perform SQL injection and extract arbitrary data from the database, including user password hashes.
Affected products
- Library Management System: from 3.5 before 3.5.8 — fixed in 3.5.8
How to fix
Upgrade to a fixed version: Library Management System 3.5.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12582 or the next vulnerability affects your stack