What’s Vulnerable › Vulnerabilities
CVE-2026-12583: Newsletters < 4.15 - Unauthenticated PHP Object Injection via Subscriber Custom Field
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-07-14
- Weakness: CWE-502
Description
The Newsletters WordPress plugin before 4.15 does not prevent deserialization of untrusted input that is stored through a public form, allowing unauthenticated attackers to inject a PHP object and, via a property-oriented gadget chain bundled with the Newsletters WordPress plugin before 4.15, write arbitrary files and execute code on the server.
Affected products
- contrid Newsletters: before 4.15 — fixed in 4.15
How to fix
Upgrade to a fixed version: contrid Newsletters 4.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12583 or the next vulnerability affects your stack