What’s Vulnerable › Vulnerabilities
CVE-2026-12644
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-19 · updated 2026-06-23
- Weakness: CWE-248
Description
Versions of the package ts-deepmerge before 8.0.0 are vulnerable to Uncaught Exception due to the improper handling of built-in Object.prototype methods (such as toString, valueOf). When user-controlled input contains these keys with non-function values, the resulting merged object becomes broken — any string context operation throws a TypeError, crashing the application.
Affected products
- ts-deepmerge: before 8.0.0 — fixed in 8.0.0
How to fix
Upgrade to a fixed version: ts-deepmerge 8.0.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/igorg1312/775fa00114c4d47df6ae0551779ab407
- https://github.com/voodoocreation/ts-deepmerge/commit/305a05831a462fb2c353d3cbbff55a0733286f8c
- https://security.snyk.io/vuln/SNYK-JS-TSDEEPMERGE-17339141
- https://gist.github.com/igorg1312/775fa00114c4d47df6ae0551779ab407
Get alerted when CVE-2026-12644 or the next vulnerability affects your stack