What’s Vulnerable › Vulnerabilities
CVE-2026-12664: Incorrect Authorization in GitLab
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-27
- Weakness: CWE-863
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an authenticated user with a read_api-scoped token to retrieve a project's incoming email address and create work items, bypassing the token's restrictions, due to insufficient scope enforcement on a GraphQL field.
Affected products
- GitLab: from 18.2.0 before 19.3.6; from 19.4.0 before 19.4.3; 19.5.0 (and their updates) — fixed in 19.3.6, 19.4.3
- GitLab: from 18.2 before 19.3.6; from 19.4 before 19.4.3; from 19.5 before 19.5.1 — fixed in 19.3.6, 19.4.3, 19.5.1
How to fix
Upgrade to a fixed version: GitLab 19.3.6, 19.4.3; GitLab 19.3.6, 19.4.3, 19.5.1. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-5-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/603510
- https://hackerone.com/reports/3735499
Get alerted when CVE-2026-12664 or the next vulnerability affects your stack