What’s Vulnerable › Vulnerabilities
CVE-2026-12689: ProfileGrid < 5.9.9.7 - Subscriber+ Cross-User Private Message Thread Deletion and Tampering via Missing Authorization
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-07-24
- Weakness: CWE-862
Description
The ProfileGrid WordPress plugin before 5.9.9.7 does not perform any authorization or ownership check on some of its private-message thread actions, allowing authenticated users with Subscriber-level access and above to soft-delete, tamper with the metadata of, and mark as read other users' private message threads.
Affected products
- metagauss ProfileGrid – User Profiles, Groups and Communities: before 5.9.9.7 — fixed in 5.9.9.7
How to fix
Upgrade to a fixed version: metagauss ProfileGrid – User Profiles, Groups and Communities 5.9.9.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12689 or the next vulnerability affects your stack